
PhysioZoo Documentation

PhysioZoo Team

Oct 20, 2020





TUTORIALS

1 Introduction 1
1.1 Installing PhysioZoo . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2
1.2 Electrocardiographic recordings . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7
1.3 Peak detection . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 9
1.4 Preprocessing . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
1.5 Heart Rate Variability analysis . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17
1.6 Signal quality annotations . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22
1.7 Importing data . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24
1.8 Formats supported . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 26
1.9 Configuration files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30
1.10 Rhythm annotations . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33
1.11 Multi-lead visualization . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 35

2 mhrv toolbox documentation 39
2.1 mhrv . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 39
2.2 mhrv.defaults . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 39
2.3 mhrv.ecg . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 39
2.4 mhrv.hrv . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 39
2.5 mhrv.rri . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 39
2.6 mhrv.wfdb . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 39
2.7 mhrv.util . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 39
2.8 mhrv.plots . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 39

3 Indices and tables 41

i



ii



CHAPTER

ONE

INTRODUCTION

PhysioZoo is a collaborative platform dedicated to the study of the heart rate variability (HRV) from Humans and
other mammals’ electrophysiological recordings. The main components of the platform are:

• Software

– An open-source algorithmic toolbox for matlab (mhrv), which implements all standard HRV analysis
algorithms, a selection of peak detection algorithms and prefiltering routines. This can be used within your
own data analysis code using the mhrv API.

– An open-source graphical user interface (PZ-UI) that provides a user friendly interface for advanced HRV
analysis of RR-intervals time series and data visualization tools. This enables easy access to HRV analysis
without writing any code.

• Databases

– A set of annotated databases (PZ-DB) of electrophysiological signals from different mammals (dog, rabbit
and mouse). Available here.

– Manually audited peak locations and signal quality annotations for each of the recordings.

• Configuration

– A set of configuration files that adapt the HRV measures and mhrv algorithms to work with data from
different mammals.

– All HRV measures can be further adapted for the analysis of other mammals by creating simple human-
readable mammal-specific configuration files.

Note: The PZ-UI user interface has two modules: a Peak detection (used to process electrophysiological
signals and obtain the RR time series) module and a HRV analysis module (used to process the RR time series
and compute HRV measures).

The PhysioZoo mission is to standardize and enable the reproducibility of HRV analysis in mammals’ electrophysio-
logical data. This is achieved through its open source code, freely available user interface and open access databases.
It also aims to encourage the scientific community to contribute their electrophysiological databases and novel HRV
algorithms/analysis tools for advancing the research in the field.

Feedback on how to improve the PhysioZoo platform is welcomed. Do not hesitate to drop us an email at:

physiozoolab@gmail.com

Source code, data or interface enhancement contributions are welcome. Look here on how to contribute to PhysioZoo.

Please include the standard citation to PhysioZoo when using the resources available on the platform:
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1.1 Installing PhysioZoo

The PhysioZoo user interface (PZ-UI) can be run from Matlab or be installed as a standalone application. If you do
not need the graphic user interface then you can directly download the HRV source code (mhrv library). PZ-UI and
mhrv were tested for Matlab 2016a and above running on Windows.

1.1.1 PhysioZoo mhrv matlab toolbox

The PhysioZoo platform includes the mhrv matlab toolbox which implements all the algorithmic functions required
by PhysioZoo (and more). The toolbox is aimed at researchers or developers that wish to write their own code for
ECG signal processing, HRV analysis or other applications by using the mhrv toolbox as a library.

See the toolbox’s ../../mhrv/sections/getting_started page for installation and initial setup instructions. The API refer-
ence for the toolbox is available on this site.

The development version of the mhrv toolbox is available here.

1.1.2 PhysioZoo PZ-UI user interface

The PhysioZoo user interface (PZ-UI) is aimed mainly at researchers working with physiologic data who do not wish
to write any code for data analysis. It provides many tools out of the box, all accessible from an interactive UI.

The UI can be run from Matlab or be installed as a standalone application. PZ-UI was tested for Matlab 2016a and
above running on Windows.

Running PZ-UI from within Matlab

Versions supported: MATLAB 2016a and above.

1. Download or clone the source code from the repository.

2. From MATLAB launch PhysioZoo by running the script PhysioZoo.m from the root of the repo.

Note: The PZ-UI user interface has two modules: a Peak detection (used to process electrophysiological
signals and obtain the RR time series) module and a HRV analysis module (used to process the RR time series
and compute HRV measures).

2 Chapter 1. Introduction
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Running PZ-UI as standalone software (.exe)

Operating system: Windows 10 (and above), 64 bits.

After downloading the software from the project’s main page, run the physiozoo.exe file. This will start the
installation process. You can then go through the following steps.

Note: Some of the screens might be slightly different depending on the version of Windows you are using and whether
you already have the MATLAB runtime compiler installed. If Matlab runtime compiler is not installed then it will be
done through this process but the installation might take some time.

1. If you get the following screen displayed then click “Run”

2. When the following screen is prompted then click “Next”

1.1. Installing PhysioZoo 3
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3. When the following screen is prompted then click “Next”

4. When the following screen is prompted check the “Yes” and then click “Next”

4 Chapter 1. Introduction
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5. When the following screen is prompted then click “Install”

6. The installation will start. Wait until it is finished. Note that this might take quite some time.

1.1. Installing PhysioZoo 5
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7. When the installation is finished it will show the following screen.

You can now click on the PhysioZoo logo located on your desktop or in the list of programs.

6 Chapter 1. Introduction
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1.2 Electrocardiographic recordings

Electrophysiological signals need to be digitized before they can be worked with. For that purpose both the range and
domain need to be digitized. Important attention should be given to the sampling frequency and quantization level in
order to ensure the integrity of the data and a meaningful HRV analysis.

1.2.1 Sampling frequency and quantization level

Sampling refers to the process of discretizing the time domain. The sampled time domain will be described by the
sampling frequency (fs) corresponding to the number of samples per second. The resulting digital signal will have a
discrete time domain.

Quantization refers to the process of constraining an input from a continuous signal to a discrete set of values. The
resulting digital signal will have a discrete range.

The sampling frequency and the quantization that are used for recording data will affect the quality of the HRV
analysis and thus it is important to inspect the raw data that are being recorded and eventually, when necessary, adjust
the sampling frequency and quantization level of the recording device.

1.2.2 Examples of typical issues

The following example shows what happens when a mouse ECG recording is downsampled from 1000 Hz to 500 Hz
and 250 Hz, thus simulating the type of signal you would record if your original sampling rate was below 1000 Hz.
As you will observe, the exact peak location is significantly affected by the sampling frequency. It is degraded at 500
Hz and at 250 Hz it will be very poor. Thus for mouse data, 1000 Hz is really the minimal sampling frequency to use
in order to ensure a meaningful HRV analysis. However, note that the adequate sampling frequency will be mammal
specific.

1.2. Electrocardiographic recordings 7
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The following example shows a rabbit recording where the quantization level was poorly set. This can be observed
by the low discretization levels / high amplitude `jumps’ between consecutive samples. A poor quantization can affect
the HRV analysis (as well as any morphological analysis).

8 Chapter 1. Introduction
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1.3 Peak detection

In this tutorial you will learn how to load an electrocardiogram (ECG) recording and perform R-peak detection. You
will also learn how to manually correct misdetected peaks. Peak detection is performed in the Peak detection
module.

1.3.1 Introduction

Accurate peak detection is critical for performing meaningfull HRV analysis. PhysioZoo provides a module to perform
accurate peak detection from different mammalian species and the option to manually correct misdetected peaks to
ensure the accuracy of the RR time series that will be analysed in the HRV analysis module.

1.3.2 Why mammal specific peak detection?

Numerous algorithms for finding R-peaks in human ECGs have been developped. However, these need to be adapted
to the different dynamics accross mammalian species. PhysioZoo provides a set of peak detection algorithms (rqrs,
jqrs and wjqrs) with parameters preset for human, dog, rabbit and mouse. Suitable parameters for other mammals
can be specified by the user from the configuration panel.

Representative example of the R-peaks detected (A) using the original gqrs human peak detector and (B) using the
rqrs PhysioZoo detector with parameters adapted for the different mammals. This figure illustrates the need for
mammal-specific R-peak detectors to ensure a correct evaluation of the RR time series.

1.3. Peak detection 9
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1.3.3 Performing peak detection in PhysioZoo

1. Open the PhysioZoo user interface PZ-UI.

2. Click “Peak Detection” on the Menu bar to open the peak detection interface.

3. Load an ECG recording (e.g. File -> Open File -> Rabbit_example.txt). The ECG will be displayed. The default
R-peak detector (rqrs) will run automatically. You will see some red crosses appearing on the ECG signal at
the locations that have been detected (panel A).

4. You can browse through the recording by stretching and moving the red window displayed in panel B. You can
also move through the recording by using the arrows circled in red on the right hand side. Finally, you can also
use the mouse scroll wheel and Ctrl scroll wheel.

Warning: The input ECG data imported in PhysioZoo MUST be in mV (i.e. physiological units). The R-peak
detector might not run appropriately if the data are not correctly scaled.

1.3.4 Manual peak correction

Sometimes the R-peak detector might make mistakes and miss some R-peaks/detect some points which are not peaks.
You can fix these mistakes manually using the PhysioZoo interface by using the following functionalities:

1. Select a part of the ECG which is noisy and where some peaks were misdetected.

2. Point your cursor on a misdetected peak or at the location where a peak is missing. When you click, PhysioZoo
will automatically remove/add a peak at this location.

3. If a whole segment contains misdetection and you need to clear all the peaks within this section, draw a rectangle
on the area where you want the peaks to be deleted (see dotted rectangle figure below). When you ‘drop the
rectangle’, all the peaks contained within it will be deleted.

4. Save your R-peak time series: File -> Save Peaks.

10 Chapter 1. Introduction
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1.3.5 Configuration for other mammals

The PhysioZoo R-peak detectors are readily adapted for human, dog, rabbit and mouse ECG data. If you need to
use them on another species then you will need to adapt their parameters accordingly. The parameters for the peak
detectors can be found under the “Config Params” tab. You can save the configuration of the peak detectors in order
to re-use it by going to File -> Save configuration file.

1.3. Peak detection 11
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For rqrs:

• HR: Typical heart rate (beats/min)

• QS: Typical QRS duration (sec)

• QT: Typical QT interval duration (sec)

• QRSa: Typical QRS peak-to-peak amplitude (microVolt)

• QRSamin: Minimum QRS peak-to-peak amplitude (microVolt)

• RRmin: Minimum RR interval (“refractory period”, sec)

• RRmax: Maximum RR interval (sec)

For jqrs and wjqrs:

• Lower cutoff frequency: the lower cutoff frequency of the bandpass filter used to prefilter the ECG (Hz)

• Upper cutoff frequency: the upper cutoff frequency of the bandpass filter used to prefilter the ECG (Hz)

• Threshold: the energy threshold (nu)

• Refractory period: the minimal time interval tolerated between two consecutive peaks (sec)

• Window size: this parameter is only used with wjqrs. This peak detector is applied on consecutive (non-
overlapping) windows of size ‘Window size’ (sec).

Other:

12 Chapter 1. Introduction
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• Peaks window: when manually correcting peaks, this parameter corresponds to the window size for which to
look for a local maximum / minimum around the click location.

1.3.6 Frequently asked questions

What is a suitable sampling frequency for my data?

In order to locate the peaks accurately from the electrophysiological signal it is important to work with data sampled
at a sufficiantly high frequency. For example, for animal data with a high heart rate such as the mouse ECG, the QRS
is only a few milliseconds long (~ 7 ms). Thus even at a relatively high sampling rate such as 1000 Hz the QRS will
only be described by very few (~7) samples. See this tutorial for a visual example.

What’s the difference between peak detectors?

Sometime a peak detector will fail to detect the R-peaks. This is due to the fact that these detectors were originally
built for human ECG analysis and extended to work with mammalian data. In animal ECGs the position and type
(e.g. subcutaneous) of the electrodes are not as standardized as for the uman. For that reason we included a set of
three R-peak detectors so that it is possible to change to the one that is performing best for your specific dataset and
electrodes configuration.

How best to deal with long recordings?

If you deal with long recordings (i.e. hours long) then use rqrs or wjqrs.

1.4 Preprocessing

In this tutorial you will learn how to preprocess your RR time series within the HRV analysis module. The
resulting preprocessed time series is traditionally called the ‘NN’ time series.

1.4.1 Introduction

When loading an RR time series in the HRV module, one of the parameters you need to set is the preprocessing
method.

We implemented in PhysioZoo three methods (and one combination of methods) for pre-filtering the RR-interval time
series:

• Range,

• Moving average,

• Quotient,

• Combined (the combination of the Range and the Moving average filters).

1.4. Preprocessing 13
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1.4.2 Why is preprocessing important?

A preprocessing step is usually performed in HRV analysis to filter out suspected ectopic beats, missed beats and
artifacts.

The example below shows an ECG segment with some transient noise. Note the miss-detected R-peaks. Leaving these
miss-detected R-peaks could lead to the evaluation of incorrect HRV measures.

Below, the corresponding RR interval time series that is filtered. The filtering allows to remove the sudden increase
and decrease in the RR time series that are caused by the miss-detected beats.

14 Chapter 1. Introduction
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1.4.3 Preprocessing methods in PhysioZoo

You can select the preprocessing filter with the dropdown “Preprocessing” located under the Main tab. You can vary
the level of preprocessing by using the dropdown “Preprocessing level” located under the Main tab. Three levels of
preprocessing are available: “Weak”, “Moderate” and “Strong”. If you want to customize the preprocessing filters
further then you can access each of the parameters of each filter by going to Options -> Filtering.

The image below shows an example of a rabbit RR time (blue time series) series which has been filtered over the
selected window (green time series) using the Moving average filter.

1.4. Preprocessing 15
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1.4.4 Frequently asked questions

Why preprocessing the RR time series?

Preprocessing methods are useful to remove local miss-labelled beats caused by noise or sudden drop/increase in the
RR time series due to ectopic beats.

What is the limitation of preprocessing routines?

In the presence of large segments of noise it will not help. Rather such large segments of bad quality data should be
discarded from the analysis. You can annotate the quality of the electrophysiological time series in order to have this
contexttual information when performing HRV analysis.

Is there instances when not to preprocess the RR time series?

If your aim is to use HRV measures for identifying certain arrythmic episodes for example then you might want to
avoid preprocessing the RR time series or to use a weak preprocessing in order to only remove outliers beats. Indeed,
in this use case you will want to capture the important irregularities (e.g. atrial fibrillation) in the RR intervals of the
time series.

16 Chapter 1. Introduction
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1.5 Heart Rate Variability analysis

In this tutorial you will learn how to compute the Heart Rate Variability (HRV) measures and export the computed
values within the PhysioZoo HRV analysis module. You will learn how to analyse a single window of defined
length and a series of consecutive windows.

1.5.1 Introduction

HRV analysis is particularly interesting because it provides a non-invasive way to monitor cardiac function and the
autonomic system activity. In particular, in the context of animal studies, HRV tools can be used to study the effects
of mutations and pharmacological treatments. PhysioZoo provides the framework and tools for performing HRV
analysis from human and animal model data.

1.5.2 Why mammal specific HRV?

Because the heart rate range, dynamics and autonomic control can vary significantly between mammals, some HRV
measures need to be adapted to the mammal whose data are being analysed. As an example, the following figure
illustrates the important differences in the location of the characteristic power spectral peaks in analysing RR time
series from different mammals using power spectral analysis. This highlights the need to re-define the spectral bands
(VLF, LF and HF) for each mammal.

1.5. Heart Rate Variability analysis 17



PhysioZoo Documentation

1.5.3 Performing HRV analysis

Start by loading some example data by clicking File -> Open data file -> mouse/Mouse_example_qrs.txt. The program
will start the analysis automatically and display the following window:

In the upper figure (A) the selected window (colored in blue) defines the time interval for which the HRV measures
are computed. In the lower panel (B), the RR time series is plotted. Two windows are drawn on it: one window with
a red frame and one with a blue frame (and alpha color from within.) The red window defines the part of the RR
time series plotted in the larger upper figure (A). The blue frame defines the part of the RR time series for which the
HRV measures will be computed. The window can be modified (extended/shrunk/moved) using the mouse. Pannel
(C) shows all the HRV measures that have been computed.

Congrats! You have made your first HRV analysis with PhysioZoo!

Note: Every time you move the analysis window to another location the newly selected segment will be automatically
analyzed. You can disable this by deselecting the checkbox “Auto Compute” located under the “Compute” button.

Note: The length of the selected window is important. Some HRV measures assume that the RR time series is
stationary over the selected window. In our context stationary means that the statistical properties of the RR time
series (such as mean and standard deviation) are about constant. Other measures such as the detrended fluctuation
analysis ones do not assume stationarity and thus a long window may be used.

18 Chapter 1. Introduction
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1.5.4 Exporting HRV measures

You can export the HRV measures and prefiltered NN intervals generated by PhysioZoo. Go to File -> Save HRV
measures. The following window will display:

You can select the computation(s) you want to save with the checkboxes:

• HRV Measures: The HRV measures as displayed in the ‘Statistics section’ of the user interface.

• Power Spectral Density: the measure of signal’s power content versus frequency. This corresponds to saving
the power content for each frequency bin of the power spectral density displayed under the ‘Frequency tab’.

• Multi Scale Entropy: the value of sample entropy for a range of scales as specified under Options->NonLinear
and displayed under the ‘NonLinear tab’.

• Preprocessed RR intervals: the RR interval time series after it was preprocessed by the filter you specified
under Main-> Preprocessing. The resulting preprocessed time series is traditionally called the ‘NN’ time series.

Select the location where you want to save the HRV measures. Open the HRV Measures file and you will see the list
of HRV measures together with their definitions and values for the window that was selected. For that purpose open
the text file (Mouse_example_qrs_hrv.txt) you just saved.

1.5. Heart Rate Variability analysis 19
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1.5.5 Exporting figures

Figures can be exported in high quality format and thus easily included in your research reports or papers. For
exporting figures click File -> Export figures. You will be prompted with the following window on which you can
choose what figures you want to export. After clicking ‘Save As’ you will be able to choose the format of the figure.

20 Chapter 1. Introduction
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1.5.6 Consecutive windows analysis

You might want to track the evolution of the HRV measures over time: for example, if you are injecting some drug to
the mammal and want to observe the resulting changes on the HRV measures over time. For that purpose PhysioZoo
enables the analysis to be performed on consecutive segments.

Let’s use a long RR time series: File -> Open data file -> Mouse_example_qrs

Click the “Single” Submenu in the left panel and click on the “Use full length” button. Then press the “Compute”
button located on the top right of the interface. You will see the following screen, which contains all the HRV measures
for each consecutive window over the whole recording.

You can also enable the analysis window to be overlapping by using the “Overlap” entry in the Analysis menu. By
default the value is 0% (i.e. no overlap between successive windows). Change it to 50% and re-run the analysis.

You can export all HRV measures from all consecutive windows (Main -> Save HRV measures as).

If you want to export figures, then select with the mouse the window you want to save the figures for.

Note: While using the successive segment analysis feature, it is possible to export the HRV measures and PSD from
all the analyzed consecutive windows together. However, you can only export the figures from one single window at
the time i.e. from the window that you select with the mouse (i.e. the ‘selected window’).

1.5. Heart Rate Variability analysis 21
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1.5.7 Adapting HRV measures to alternative mammals

If you want to adapt the HRV measures to other mammals you can create a new ‘Configuration file’ (see here) with
parameters suitable to the specie you are studying. For some of the HRV measures (power frequency bands and
pNNxx) you will find a button ‘E’ next to their parameters value under Options->Time/Frequency. You can use click
on this button to adapt the HRV measure to the alternative mammalian model you are using.

1.5.8 Video Example

1.6 Signal quality annotations

In this tutorial you will learn how to perform signal quality annotations within the PhysioZoo Peak detection
module and how to use these for your analysis in order to provide contextual information.

1.6.1 Introduction

PhysioZoo allows you to annotate and load signal quality annotations, which contain time intervals with quality
annotations made on the original electrophysiological signal time series. The annotations highlight parts of the RR
time series which are not to be trusted because the underlying ECG was of bad quality and the peak detector might have
failed in estimating the heart rate within these intervals or just because you want to exclude these segments because
they correspond to some transition period during drug injection and so you decide to label these time periods as ‘bad
quality’.

22 Chapter 1. Introduction
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1.6.2 Annotating signal quality

To annotate the quality of an electrophysiological signal time series, follow these steps:

1. Select the rabbit ECG example: File-> Open data file-> Rabbit_example.txt

2. Under the record panel, select Annotation -> Signal quality. See the red rectangle on the figure below.

3. Look for a segment with some bad quality data and draw a rectangle around it with the mouse. The background
of the area you have selected will become red.

In PhysioZoo we define three levels of signal quality:

• “A”: good quality signal where HRV and morphological analysis of the electrophysiological signal are possible.
This means that the waveform is clean enough to detect the beats and to also study its morphology.

• “B”: average quality signal where the beats can be detected and thus HRV analysis is possible but the signal
quality is not good enough for morphological analysis.

• “C”: bad quality signal. Neither HRV or morphological analysis is possible.

1.6.3 Loading signal quality

When using a recording for which you have performed signal quality annotations, you can load the signal quality
annotations: Open -> Open signal quality file.

After the quality annotations are loaded, you will see a bar with green and red parts appearing on the top of the RR
interval time series figure. The part in green corresponds to good quality data (i.e. data which analysis can be trusted)
and the part in red corresponds to bad quality data (i.e. data which should not be trusted.) In addition, the RR time
series is highlighted in red for the intervals which are indicated as bad quality.

1.6. Signal quality annotations 23
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1.6.4 Frequently asked questions

When do we need to make signal quality annotations?

Small bad quality segments (few of beats) will be ‘cleaned up’ by the prefiltering step and so one should not worry too
much about it. The signal quality annotations are more useful when a ‘large’ section of the recording is of bad quality
in which case the prefiltering step will be useless or even misleading. Analysing such sections with large segments of
bad quality data will provide meaningless results - the signal quality annotations are useful to prevent that.

1.7 Importing data

In this tutorial you will learn how to import data in PhysioZoo.

24 Chapter 1. Introduction
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1.7.1 Introduction

Data loading in PhysioZoo is centralized and done through the PZ Loader tool. Three types of input formats are
supported by PhysioZoo - see formats supported.

1.7.2 Concepts

• PZ Loader: three types of formats can be loaded in PhysioZoo. This is done through the PZ Loader. The
PZ Loader will ensure that the data that enter the PZ-UI are properly formatted.

• Header: it is possible to include a header at the beginning of a record. This header will specify all the information
that PhysioZoo needs to open a record. If all the information is specified in the header, then you will not need
to go through populating the PZ Loader User Interface and the record will be directly opened in PhysioZoo.

See here for the formats supported and how to create PhysioZoo headers.

The figure below illustrates the pathway for loading a recording: the PZ Loader is used to load a recording from
one of the supported formats. If no header is available, then the PZ Loader user interface is opened and the user is
prompted to enter the necessary information. If the header is available, then the record is directly loaded in PhysioZoo.

In this tutorial we will see how to make use of the PZ Loader user interface (UI) when no header is available.

1.7.3 PZ Loader User Interface

Open an example annotation file:

Download the following example file and load it in PhysioZoo.

In case some information is missing from the file (e.g. mammal type is not available in the header) then the PZ
Loader will request the corresponding fields to be filled by the user. When all the fields have been filled then click
OK and the data will be opened in PhysioZoo.

For the example provided, fill the fields as in the screenshot below and click OK:
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1.8 Formats supported

In this tutorial you will learn about how to prepare your data for importing them in PhysioZoo. Data samples are
available here.

1.8.1 Introduction

PhysioZoo supports three types of formats:

• WFDB,

• text (.txt),

• MATLAB (.mat).

The .txt and .mat files structures are specific to PhysioZoo whereas the WFDB follows the standard structure of WFDB
powered by Physionet (physionet.org) with some additional fields in the WFDB header files. If you are experienced
with WFDB then we recommend you use this format.

For any of the three formats a file consists of a “header” and the “data”:
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Note: When downloading PhysioZoo a set of examples (WFDB,.txt and .mat) are provided with the structure that is
needed in PhysioZoo. You can use these as examples for formatting your own recordings.

1.8.2 General structure of the Header

For each of the files the following information can be specified in the header:

• Mammal: the name of the mammal (e.g. ‘dog’, ‘mouse’, ‘rabbit’, ‘human’),

• Fs: the sampling frequency in Hertz,

• Integration_Level: ‘electrocardiogram’, ‘electrogram’ or ‘action potential’.

As part of the header, information characterizing each channel available can be entered:

• type: ‘peak’, ‘signal quality’, ‘time’, ‘interval’, ‘beating rate’ and ‘electrography’. See definitions of these in
the next section,

• name: a name you want to give to the channel (of note this information is not used by the PZ Loader to load the
data),

• unit: ‘millisecond’, ‘second’, ‘index’, ‘bpm’, ‘millivolt’, ‘microvolt’ and ‘volt’,

• enable: ‘yes’ or ‘no’. If you specify ‘no’ then this channel will be ignored when the file is loaded by the PZ
Loader. Only specify ‘yes’ for the channels you want to use.

In the case all or some of this information is missing from the Header then you will be prompted to enter it through
the PZ Loader User Interface.
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1.8.3 Channels Type

There are two categories of Channels: ‘Annotations’ and ‘Time series’. Within these two categories the Channel can
be one of the following type’s (specified in the header):

Annotations

• ‘peak’: the location of the peaks (e.g. R-peak from an ECG time series). The peak locations can be
specified in millisecond/second or index.

• ‘signal quality’: annotation on the signal quality. The signal quality annotations can be specified in mil-
lisecond/second or index.

Time series

• ‘time’: a time vector giving the position of each sample of another time series. An entry of type ‘time’
needs to be associated with another time series and must be in units of seconds or milliseconds.

• ‘interval’: the time interval between consecutive beats (e.g. RR time series). The interval length can be
specified in second/millisecond or index.

• ‘beating rate’: the reciprocal of the interval in units of beats per minute (e.g. heart rate).

• ‘electrography’: the amplitude of an electrography time series (e.g. ECG). The electrography amplitude is
given in microvolt, millivolt or volt. Thus only physiological units are allowed.

1.8.4 Headers in the different formats

Explanation of the structure of the different formats supported is provided below. Examples in all formats are also
available in the ‘Examples’ folder provided with the PhysioZoo download.

Text format (.txt)
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Matlab format (.mat)

A .mat file needs to contain the following fields:

The Channels field is a Cell. Each element of the Channel Cell will contain the following fields : ‘type’, ‘name’, ‘unit’
and ‘enable’.

WFDB (.hea)

WFDB files (annotation or data) will be accompanied by a header (.hea) file specifying the relevant information for
reading an annotation or data file. Refer to the WFDB documentation for that. To the standard WFDB format of the
header, you will need to add one comment line at the end of the header and starting ‘#’ then followed by the mammal
type and the integration level.
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1.8.5 Frequently asked questions

What if I am used to another format?

For now PhysioZoo only supports the WFDB, text and Matlab formats. Most commercial softwares enable you to
export your data in text format which you can then import in PhysioZoo using the PZ Loader (see here).

Is there a way to import data without a formatted header?

Yes you can use the PZ Loader (see here) to import data which do not have a Header. You will use the PZ Loader
User Interface to fill in the information needed and it will be opened in PhysioZoo.

1.9 Configuration files

In this tutorial you will learn how to create your custom configuration files for R-peak detection and for performing
HRV analysis.

Note: In the next version of PhysioZoo the two configuration files will be merged in one unique configuration file.

1.9.1 Introduction

PhysioZoo enables you to work with HRV data from different mammals. Since the beating rate and its variability
patterns vary across species then some parameters of the peak detectors and of the time, frequency and nonlinear HRV
measures must be adjusted.

In the current version of the software these adaptations are readily available for the processing of Human, dog, rabbit
and mouse electrocardiographic data. For processing data from other species or if you are using other data than ECG
(e.g. electrogram, action potential) you will need to define your own configuration files. There are two types of
configuration files in PhysioZoo: the peak detection configuration file and the HRV configuration file.

1.9.2 PhysioZoo software

Defining a peak detector configuration file

In the Peak detection module:

1. By choosing Mammal->Custom this will prompt you with a selection window. Select the configuration file of
the closest mammal to the one you want to use. This will set the default HRV configuration parameters. Follow
the following steps:

2. Modify the configuration of the peak detector you choose to use uder Configuration.
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3. Save the peak detector configuration by clicking File -> Save configuration file.

4. To use this configuration file when you next use the PhysioZoo peak detection module: (1) File->Load custom
config file or (2) Main->Mammal->Custom and choose your configuration file.

Defining an HRV configuration file

In the HRV module: under the “Main” tab you can change the Mammal type to one of the following options: Human,
Dog, Rabbit, Mouse and Custom. In built in the software are configuration files for human, dog, rabbit and mouse
electrocardiographic data. By choosing thee “Custom” option under `Mammal’ you can define an HRV configuration
file of your own. Follow the following steps:

1. By choosing Mammal->Custom this will prompt you with a selection window. Select the configuration file of
the closest mammal to the one you want to use. This will set the default HRV configuration parameters.

2. Modify some of the HRV measures configuration by going to the “Options” menu (see screenshot below.) There
you will find all the parameters of the HRV measures sorted with respect to their category: Time, Frequency and
Nonlinear as well as the Preprocessing parameters. If, as an example, you want to change the cut-off frequency
between the low frequency and high frequency bands (“LF Band” and “HF Band”) in the frequency based
methods then you can do so by changing the 0.341 Hz (see screen below) value to something else more suited
to your data.

3. Go to File->Save config file and save the configuration file under the name of the mammal you are using.

4. To use this configuration file when you next use PhysioZoo HRV module: (1) File->Load custom config file or
(2) Main->Mammal->Custom and choose your configuration file.
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1.9.3 Frequently asked questions

Why configuration files?

The beating rate and its variability pattern vary across species thus some parameters of the peak detectors and of the
time, frequency and nonlinear HRV measures must be adjusted.

1.10 Rhythm annotations

In this tutorial you will learn how to perform rhythms annotations from raw ECG recording within the PhysioZoo
Peak detection module.

1.10.1 Introduction

PhysioZoo enables you to annotate and load rhythm annotations i.e. timestamped rhythm annotations marking the
beginning and the end of a given rhythm. For example, rhythm annotations may have been produced by an original
automated analysis machine (e.g. Holter ECG software) that you which to review and edit. The heart rhythms for
which annotations exist in PhysioZoo are:

Table 1: Available rhythms in PhysioZoo
Abbreviation Condition
AFIB Atrial fibrillation
AB Atrial bigeminy
AFL Atrial flutter
B Ventricular bigeminy
BII 2° heart block
IVR Idioventricular rhythm
NOD Nodal (A-V junctional) rhythm
P Paced rhythm
PREX Pre-excitation (WPW)
SBR Sinus bradycardia
SVTA Supraventricular tachyarrhythmia
T Ventricular trigeminy
VFL Ventricular flutter
VT Ventricular tachycardia
J Junctional rhythm
PAT Paroxysmal atrial tachycardia
AT Atrial tachycardia
IVR Idioventricular rhythm
AIVR Accelerated idioventricular rhythm
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1.10.2 Annotating rhythms

To annotate the quality of an electrophysiological signal time series, follow these steps:

1. Select the following ECG example: File-> Open data file-> physiozoo\ExamplesTXT\rhythms\ECG.txt.

2. Under the record panel, select Annotation -> Rhythms. See the red rectangle on the figure below. The different
options will be displayed below in the same panel.

3. Draw a rectangle with your mouse on the desired window. The background behind the selected window will be
displayed in color.

4. The rhythms can be exported under a .txt file: File -> Save Rhythms file (Ctrl+T).

1.10.3 Loading rhythms

When using a recording for which you have performed rhythms annotations, you can load the rhythms annotations:
Open -> Open rhythms file.

After the rhythms annotations are loaded, you will see a set of shaded areas with different colors appearing on the
top of the RR interval time series figure as well as on the ECG raw data. These areas correspond to the rhythms
annotations and each color is used to represent a different rhythm. These annotations may be further edited/saved.

On the bottom panel, you can find summary statistics for each rhythm: burden, minimal interval length, maximal
interval length and 5 summary statistics.
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1.11 Multi-lead visualization

In this tutorial you will learn how to visualize several ECG channels within the PhysioZoo Peak detection
module.

1.11.1 Introduction

PhysioZoo allows you to visualize several ECG channels in parallel. TThis can be use to facilitate the review of Holter
recordings for example. This tutorial will show how to display several channels in parallel.

1.11.2 Displaying several leads

To display several channels of an ECG, follow these steps:

1. Select the multi-lead ECG example: File-> Open data file-> physiozoo\ExamplesTXT\multi-lead\multi-lead.txt.

2. On the right panel, select the desired channels to be displayed. By default, only channel 1 is selected.
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1.11.3 Frequently asked questions

What is the format of the files to be loaded to **PhysioZoo to display several channels ?**

If recordings are provided in .mat format then each column will represent a different lead.

An other option is to use a .txt file which will contain the following header:

—
Mammal: Mammal type (human, rabbit. . . )
Fs: Sampling frequency
Integration_level: electrocardiogram

Channels:

- type: electrography
name: Channel name
unit: Units (usually mV)
enable: yes

- type: electrography
name: Channel name
unit: Units (usually mV)
enable: yes

- type: electrography
name: Channel name
unit: Units (usually mV)
enable: yes
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—

Following this header, the user shall place the samples in 3 distinct columns, separated by a space. The user is invited
to open the ‘multi-lead.txt’ example to visualize the structure of the file.
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MHRV TOOLBOX DOCUMENTATION

2.1 mhrv

2.2 mhrv.defaults

2.3 mhrv.ecg

2.4 mhrv.hrv

2.5 mhrv.rri

2.6 mhrv.wfdb

2.7 mhrv.util

2.8 mhrv.plots
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INDICES AND TABLES

• genindex

• modindex

• search

41


	Introduction
	Installing PhysioZoo
	Electrocardiographic recordings
	Peak detection
	Preprocessing
	Heart Rate Variability analysis
	Signal quality annotations
	Importing data
	Formats supported
	Configuration files
	Rhythm annotations
	Multi-lead visualization

	mhrv toolbox documentation
	mhrv
	mhrv.defaults
	mhrv.ecg
	mhrv.hrv
	mhrv.rri
	mhrv.wfdb
	mhrv.util
	mhrv.plots

	Indices and tables

