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CHAPTER
ONE

INTRODUCTION

PhysioZoo is a collaborative platform dedicated to the study of the heart rate variability (HRV) from Humans and
other mammals’ electrophysiological recordings. The main components of the platform are:

* Software

— An open-source algorithmic toolbox for matlab (mhrv), which implements all standard HRV analysis
algorithms, a selection of peak detection algorithms and prefiltering routines. This can be used within your
own data analysis code using the mhrv APL

— An open-source graphical user interface (PZ—-UTI) that provides a user friendly interface for advanced HRV
analysis of RR-intervals time series and data visualization tools. This enables easy access to HRV analysis
without writing any code.

e Databases

— A set of annotated databases (P Z—DB) of electrophysiological signals from different mammals (dog, rabbit
and mouse). Available here.

— Manually audited peak locations and signal quality annotations for each of the recordings.
» Configuration

— A set of configuration files that adapt the HRV measures and mhrv algorithms to work with data from
different mammals.

— All HRV measures can be further adapted for the analysis of other mammals by creating simple human-
readable mammal-specific configuration files.

Note: The PZ-UTI user interface has two modules: a Peak detection (used to process electrophysiological
signals and obtain the RR time series) module and a HRV analysis module (used to process the RR time series
and compute HRV measures).

The PhysioZoo mission is to standardize and enable the reproducibility of HRV analysis in mammals’ electrophysio-
logical data. This is achieved through its open source code, freely available user interface and open access databases.
It also aims to encourage the scientific community to contribute their electrophysiological databases and novel HRV
algorithms/analysis tools for advancing the research in the field.

Feedback on how to improve the PhysioZoo platform is welcomed. Do not hesitate to drop us an email at:
physiozoolab@ gmail.com
Source code, data or interface enhancement contributions are welcome. Look here on how to contribute to PhysioZoo.

Please include the standard citation to PhysioZoo when using the resources available on the platform:



https://drive.google.com/file/d/1waDbfJlCWLGWTfaV7_tJ1j2-4Re5N5OG/view?usp=sharing
mailto:physiozoolab@gmail.com
https://physiozoo.com/about/
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1.1 Installing PhysioZoo

The PhysioZoo user interface (PZ—-UI) can be run from Matlab or be installed as a standalone application. If you do
not need the graphic user interface then you can directly download the HRV source code (mhrv library). PZ-UT and
mhrv were tested for Matlab 2016a and above running on Windows.

1.1.1 PhysioZoo mhrv matlab toolbox

The PhysioZoo platform includes the mhrv matlab toolbox which implements all the algorithmic functions required
by PhysioZoo (and more). The toolbox is aimed at researchers or developers that wish to write their own code for
ECG signal processing, HRV analysis or other applications by using the mhrv toolbox as a library.

See the toolbox’s ../../mhrv/sections/getting_started page for installation and initial setup instructions. The API refer-
ence for the toolbox is available on this site.

The development version of the mhrv toolbox is available here.

1.1.2 PhysioZoo Pz-UI user interface

The PhysioZoo user interface (P Z—-UT) is aimed mainly at researchers working with physiologic data who do not wish
to write any code for data analysis. It provides many tools out of the box, all accessible from an interactive UL

The UI can be run from Matlab or be installed as a standalone application. PZ-UT was tested for Matlab 2016a and
above running on Windows.

Running Pz-UI from within Matlab

Versions supported: MATLAB 2016a and above.
1. Download or clone the source code from the repository.

2. From MATLAB launch PhysioZoo by running the script PhysioZoo . m from the root of the repo.

Note: The PZ-UTI user interface has two modules: a Peak detection (used to process electrophysiological
signals and obtain the RR time series) module and a HRV analysis module (used to process the RR time series
and compute HRV measures).
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Running Pz-UI as standalone software (.exe)

Operating system: Windows 10 (and above), 64 bits.

After downloading the software from the project’s main page, run the physiozoo.exe file. This will start the
installation process. You can then go through the following steps.

Note: Some of the screens might be slightly different depending on the version of Windows you are using and whether
you already have the MATLAB runtime compiler installed. If Matlab runtime compiler is not installed then it will be
done through this process but the installation might take some time.

1. If you get the following screen displayed then click “Run”

SmartScreen can't be reached right now

2. When the following screen is prompted then click “Next”

1.1. Installing PhysioZoo 3
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P PhysioZoo Installer - a X

Connection Settings

PhysioZoo 1.0

Heart Rate Variability Analysis from Mammals Electrophysiological Data
Technion BBS Laboratory

physiozoolab@gmail.com

3. When the following screen is prompted then click “Next”

P Required Software - O X

MATLAB Runtime is required.

Choose installation folder: M K [11 A B
s

“A\Program Files\MATLAB\MATLAB Runtime Browse...

R2017a

Restore Default Folder

MATLAB and Simulink are registered trademarks of The MathWorks, Inc. Please see
mathworks.com/trademarks for a list of additional trademarks. Other product or brand names may
be trademarks or registered trademarks of their respective holders.

WARNING: This program is protected by copyright law and international treaties. Copyright
1984-2017, The MathWorks, Inc. Protected by U.S. and other patents. See MathWorks.com/patents

) MathWorks-

4. When the following screen is prompted check the “Yes” and then click “Next”
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P License Agreement — O %
The MathWorks, Inc. i
MATLAB RUNTIME LICENSE

IMPORTANT NOTICE
BY CLICKING THE "YES™ BUTTON BELOW, YOU ACCEPT THE TERMS OF THIS LICENSE. IF YOU ARE NOT WILLING TO DO SO,
SELECT THE "NO" BUTTON AND THE INSTALLATION WILL BE ABORTED.

1. LICENSE GRANT. Subject to the restrictions below, The MathWorks, Inc. ("MathWorks") hereby grants to you, whether
you are an individual or an entity, a license to install and use the MATLAB Runtime (“Runtime”), solely and expressly for the
purpose of running software created with the MATLAB Compiler (the “Application Software"), and for no other purpose.
This license is personal, nonexclusive, and nontransferable.

2. LICENSE RESTRICTIONS. You shall net modify or adapt the Runtime for any reason. You shall not disassemble,
decompile, or reverse engineer the Runtime. You shall not alter or remove any proprietary or other legal notices on or in
copies of the Runtime. Unless used to run Application Software, you shall not rent, lease, or loan the Runtime, time share
the Runtime, provide service bureau use, or use the Runtime for supporting any other party’s use of the Runtime. You shall
not sublicense, sell, or otherwise transfer the Runtime to any third party. You shall not republish any documentation which
_mawu he nrovided in connection with the Buntime All rinhts not aranted _includina withaot limitation rinhts to renradoce

Do you accept the terms of the license agreement? @E JINo

) MatkWorks

5. When the following screen is prompted then click “Install”

P Confirmation — O e

PhysioZoo will be installed in:
C\Program Files\Technion\PhysioZoo

PhysioZoo requires MATLAB Runtime R2017a.

MATLAB Runtime R2017a is already installed in:
C\Program Files\MATLAB\MATLAB Runtime\w92

intal >

6. The installation will start. Wait until it is finished. Note that this might take quite some time.
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P 45% Complete - O *

Performing post-installation tasks. This may take a few moments...

I %

Cancel

7. When the installation is finished it will show the following screen.

%P Installation Complete - O X

Installation completed successfully.

You can now click on the PhysioZoo logo located on your desktop or in the list of programs.
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1.2 Electrocardiographic recordings

Electrophysiological signals need to be digitized before they can be worked with. For that purpose both the range and
domain need to be digitized. Important attention should be given to the sampling frequency and quantization level in
order to ensure the integrity of the data and a meaningful HRV analysis.

1.2.1 Sampling frequency and quantization level

Sampling refers to the process of discretizing the time domain. The sampled time domain will be described by the
sampling frequency (fs) corresponding to the number of samples per second. The resulting digital signal will have a
discrete time domain.

Quantization refers to the process of constraining an input from a continuous signal to a discrete set of values. The
resulting digital signal will have a discrete range.

The sampling frequency and the quantization that are used for recording data will affect the quality of the HRV
analysis and thus it is important to inspect the raw data that are being recorded and eventually, when necessary, adjust
the sampling frequency and quantization level of the recording device.

1.2.2 Examples of typical issues

The following example shows what happens when a mouse ECG recording is downsampled from 1000 Hz to 500 Hz
and 250 Hz, thus simulating the type of signal you would record if your original sampling rate was below 1000 Hz.
As you will observe, the exact peak location is significantly affected by the sampling frequency. It is degraded at 500
Hz and at 250 Hz it will be very poor. Thus for mouse data, 1000 Hz is really the minimal sampling frequency to use
in order to ensure a meaningful HRV analysis. However, note that the adequate sampling frequency will be mammal
specific.

1.2. Electrocardiographic recordings 7
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The following example shows a rabbit recording where the quantization level was poorly set. This can be observed
by the low discretization levels / high amplitude “jumps’ between consecutive samples. A poor quantization can affect
the HRV analysis (as well as any morphological analysis).
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1.3 Peak detection

In this tutorial you will learn how to load an electrocardiogram (ECG) recording and perform R-peak detection. You
will also learn how to manually correct misdetected peaks. Peak detection is performed in the Peak detection
module.

1.3.1 Introduction

Accurate peak detection is critical for performing meaningfull HRV analysis. PhysioZoo provides a module to perform
accurate peak detection from different mammalian species and the option to manually correct misdetected peaks to
ensure the accuracy of the RR time series that will be analysed in the HRV analysis module.

1.3.2 Why mammal specific peak detection?

Numerous algorithms for finding R-peaks in human ECGs have been developped. However, these need to be adapted
to the different dynamics accross mammalian species. PhysioZoo provides a set of peak detection algorithms (rgrs,
jagrs and wjgrs) with parameters preset for human, dog, rabbit and mouse. Suitable parameters for other mammals
can be specified by the user from the configuration panel.

Representative example of the R-peaks detected (A) using the original ggrs human peak detector and (B) using the
rgrs PhysioZoo detector with parameters adapted for the different mammals. This figure illustrates the need for
mammal-specific R-peak detectors to ensure a correct evaluation of the RR time series.
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1.3.3 Performing peak detection in PhysioZoo

1. Open the PhysioZoo user interface PZ-UT.
2. Click “Peak Detection” on the Menu bar to open the peak detection interface.

3. Load an ECG recording (e.g. File -> Open File -> Rabbit_example.txt). The ECG will be displayed. The default
R-peak detector (rgrs) will run automatically. You will see some red crosses appearing on the ECG signal at
the locations that have been detected (panel A).

4. You can browse through the recording by stretching and moving the red window displayed in panel B. You can
also move through the recording by using the arrows circled in red on the right hand side. Finally, you can also
use the mouse scroll wheel and Ctrl scroll wheel.

PhysioZoo_PeakDetection — X
File ~
Record Configuration Display C:\Users\Joachim.T-BM-YY-L6\D: i physiozoo-toolbox-8d644191c06 plesTXT\rabbi it_example_ecg.txt | compute |
Record file name: Rabbit_example_ecg it - e P
Peaks file name: m“"mmm]l“hﬂh ) | X $ oo i ’ Plot HR
Sy e 5 ﬂh]]ﬂllﬂ‘]ﬂ H“mmmnmlmmm“““M”NMI]“ﬂl | mr “ M wil i
¢ L IV T
Time series length: 0:26:0.277 h'min‘sec.msec @ o ] || ]l |
o
Mammal Rabbit M o
Integration level ECG = 021
Peak detector rars . I I | | | |
00:00:00 00:00:10 00:00:20 00:00:30 00:00:40 00:00:50 00:01:00
Annotation Peak v Time (sec)
< 1F
T s
L] i MMMP I N N S N EE—.
- ’; L S| I M I I
00:00:00 00:08:20 00:16:40 00:25:00
Description Values
NB PEAKS (n.u) Total number of peaks 5449
NB PEAKS ADD (n) Number of peaks manually added by the user 0
NB PEAKS RM (1) Number of peaks manually removed by the user 0
PRBAD SQ (%) Percentage of the record annotated as bad quality (i.e. signal quality = 'A’) 0

Warning: The input ECG data imported in PhysioZoo MUST be in mV (i.e. physiological units). The R-peak
detector might not run appropriately if the data are not correctly scaled.

1.3.4 Manual peak correction
Sometimes the R-peak detector might make mistakes and miss some R-peaks/detect some points which are not peaks.
You can fix these mistakes manually using the PhysioZoo interface by using the following functionalities:

1. Select a part of the ECG which is noisy and where some peaks were misdetected.

2. Point your cursor on a misdetected peak or at the location where a peak is missing. When you click, PhysioZoo
will automatically remove/add a peak at this location.

3. If a whole segment contains misdetection and you need to clear all the peaks within this section, draw a rectangle
on the area where you want the peaks to be deleted (see dotted rectangle figure below). When you ‘drop the
rectangle’, all the peaks contained within it will be deleted.

4. Save your R-peak time series: File -> Save Peaks.
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PhysioZoo_PeakDetection - X
File »
Record Configuration Display Ci\Users\Joachim. T-BM-Y Y-L6\D i physi toolbox-8d644191c06 TXT\rabbit\Rabbit_example_ecg.txt | compute |
Record file name: Rabbit_example_ecg.txt = U [lAuto Com
Peaks file name: 4r Plot HR
Sy Fomm s 2
E
Time series length: 0:26:0.277 h:min-sec.msec ® 0
O
w
Mammal Rabbit w ok
Integration level ECG w 4l
Peak detector rars w L L L L L L L
00:16:45 00:16:50 00:16:55 00:17:00 00:17:05 00:17:10 00:17:15
Annotation Peak v Time (sec)
5 1k
8
~ 05— u
. ] O N R— b N X E— ‘,y_MlUW‘*,

0= 1
“ . 00:00:00 00:08:20 00:16:40 00:25:00 gg

Description Values

NB PEAKS (n.u) Total number of peaks 5449
NB PEAKS ADD (nu) Number of peaks manually added by the user o
NB PEAKS RM (n.u) Number of peaks manually removed by the user o
PR BAD 5Q (%) Percentage of the record annotated as bad quality (i.e. signal quality ='A’) 0

1.3.5 Configuration for other mammals

The PhysioZoo R-peak detectors are readily adapted for human, dog, rabbit and mouse ECG data. If you need to
use them on another species then you will need to adapt their parameters accordingly. The parameters for the peak
detectors can be found under the “Config Params” tab. You can save the configuration of the peak detectors in order
to re-use it by going to File -> Save configuration file.

1.3. Peak detection 11
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Record Configuration Display
rqrs
HR 264 BPM
Qs 0.02 sec
QT 0.12 sec
QRSa 294 uVolts
QRSamin 114 uVolts
RRmin 014 sec
RRmax 0.58 sec
jqrsiwijqrs
Lower cutoff frequency 3 Hz
Upper cutoff frequency 150 Hz
Threshold 0.5 n.u.
Refractory period 0.088 Sec
Window size 10 sec
[v] Auto
Peaks window 40 ms

For rgrs:
* HR: Typical heart rate (beats/min)
* QS: Typical QRS duration (sec)
* QT: Typical QT interval duration (sec)
* QRSa: Typical QRS peak-to-peak amplitude (microVolt)
* QRSamin: Minimum QRS peak-to-peak amplitude (microVolt)
* RRmin: Minimum RR interval (“refractory period”, sec)
¢ RRmax: Maximum RR interval (sec)
For jgrs and wjgrs:
* Lower cutoff frequency: the lower cutoff frequency of the bandpass filter used to prefilter the ECG (Hz)
» Upper cutoff frequency: the upper cutoff frequency of the bandpass filter used to prefilter the ECG (Hz)
* Threshold: the energy threshold (nu)
* Refractory period: the minimal time interval tolerated between two consecutive peaks (sec)

* Window size: this parameter is only used with wjqrs. This peak detector is applied on consecutive (non-
overlapping) windows of size “Window size’ (sec).

Other:

12 Chapter 1. Introduction
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* Peaks window: when manually correcting peaks, this parameter corresponds to the window size for which to
look for a local maximum / minimum around the click location.

1.3.6 Frequently asked questions

What is a suitable sampling frequency for my data?

In order to locate the peaks accurately from the electrophysiological signal it is important to work with data sampled
at a sufficiantly high frequency. For example, for animal data with a high heart rate such as the mouse ECG, the QRS
is only a few milliseconds long (~ 7 ms). Thus even at a relatively high sampling rate such as 1000 Hz the QRS will
only be described by very few (~7) samples. See this tutorial for a visual example.

What'’s the difference between peak detectors?

Sometime a peak detector will fail to detect the R-peaks. This is due to the fact that these detectors were originally
built for human ECG analysis and extended to work with mammalian data. In animal ECGs the position and type
(e.g. subcutaneous) of the electrodes are not as standardized as for the uman. For that reason we included a set of
three R-peak detectors so that it is possible to change to the one that is performing best for your specific dataset and
electrodes configuration.

How best to deal with long recordings?

If you deal with long recordings (i.e. hours long) then use rgrs or wjgrs.

1.4 Preprocessing

In this tutorial you will learn how to preprocess your RR time series within the HRV analysis module. The
resulting preprocessed time series is traditionally called the ‘NN’ time series.

1.4.1 Introduction
When loading an RR time series in the HRV module, one of the parameters you need to set is the preprocessing
method.

We implemented in PhysioZoo three methods (and one combination of methods) for pre-filtering the RR-interval time
series:

* Range,
* Moving average,
¢ Quotient,

* Combined (the combination of the Range and the Moving average filters).

1.4. Preprocessing 13


../tutorials/peakdetection.html

PhysioZoo Documentation

1.4.2 Why is preprocessing important?

A preprocessing step is usually performed in HRV analysis to filter out suspected ectopic beats, missed beats and
artifacts.

The example below shows an ECG segment with some transient noise. Note the miss-detected R-peaks. Leaving these
miss-detected R-peaks could lead to the evaluation of incorrect HRV measures.

10

ECG (mV)
~]

—ECG signal
% R-peaks
1

4 | 1 | |
4310 4312 4314 4316 4318 4320
Time (sec)

Below, the corresponding RR interval time series that is filtered. The filtering allows to remove the sudden increase
and decrease in the RR time series that are caused by the miss-detected beats.
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1.4-
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ad A Range outliers
o Lowpass outliers
0.4 = Quotient outliers
——window average
---window threshold
0.2 : : : : '
4280 4290 4300 4310 4320 4330
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1.4.3 Preprocessing methods in PhysioZoo

You can select the preprocessing filter with the dropdown “Preprocessing” located under the Main tab. You can vary
the level of preprocessing by using the dropdown “Preprocessing level” located under the Main tab. Three levels of
preprocessing are available: “Weak”, “Moderate” and “Strong”. If you want to customize the preprocessing filters
further then you can access each of the parameters of each filter by going to Options -> Filtering.

The image below shows an example of a rabbit RR time (blue time series) series which has been filtered over the
selected window (green time series) using the Moving average filter.

1.4. Preprocessing 15
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P Physiozoo - X
File Peak Detection >
Main Single  Options  Display C:\Users\Joachim.T-BM-YY-L6\D y: to0lbox-8d64419 TXT\ e G G [~ compute |
T T T T
File name Rabbit_example_grs.txt Auto Compute
04
Signal quality file name Plot HR
0.35 -
Time series length 00:25:59.974  h:min:sec.msec 5
S 03
Mamml Rabbit . = M
Z o2l
Integration level v
ECG ol
Preprocessin =
” ° Moving average <: 0.15 Time series Selected filtered timf series
Preprocessing level Default = e L L L L L L
00:00:00  00:01:40  00:03:20  00:05:00  00:06:40  00:08:20  00:10:00  00:11:40  00:13:20  00:15:00
Default frequency method \weich v Time (h:min:sec)
04
035
| ™ Lol
oozg M 'L 1 P T
. M I
00:00:00 00:08:20 00:16:40 00:25:00 gg
Statistics Time Frequency NonLinear
Description Values
AVNN (ms) Average NN interval duration 281.30 o
SDNN (ms) Standard deviation of NN interval duration 1027
RMSSD (ms) The square root of the mean of the sum of the squares of differences between adjacent NN intervals 6.89
PNN1T (%) Percent of NN interval differences greater than 17.0milliseconds 113
SEM (ms) Standard error of the mean NN interval 032
PIP (%) Percentage of inflection points in the NN interval time series 49.58
1ALS (nu) Inverse average length of the acceleration/deceleration segments 050
PSS (%) Percentage of short segments 45.99
PAS (%) The percentage of NN intervals in alternation segments 2077
B WELCH (nu) Slope of the linear interpolation of the spectrum in a log-log scale for frequencies below the upper bound of the VLF band 070
HF NORM WELCH (%) High frequency power in normalized units: HF/(Total power - VLF)*100 (welch) 41.90
HF PEAK WELCH (H2) Peak frequency in the high frequency band (welch) 051
HF WELCH (ms™2) Power in the high frequency band (welch) 14.95
LF NORM WELCH (%) Low frequency power in normalized units: LF/(Total power - VLF)*100 (welch) 58.10
LF PEAK WELCH (Hz) Peak frequency in the low frequency band (welch) 0.09
LFWELCH (ms?2) Power in the low frequency band (welch) 2073 .

1.4.4 Frequently asked questions
Why preprocessing the RR time series?

Preprocessing methods are useful to remove local miss-labelled beats caused by noise or sudden drop/increase in the
RR time series due to ectopic beats.

What is the limitation of preprocessing routines?

In the presence of large segments of noise it will not help. Rather such large segments of bad quality data should be
discarded from the analysis. You can annotate the quality of the electrophysiological time series in order to have this
contexttual information when performing HRV analysis.

Is there instances when not to preprocess the RR time series?

If your aim is to use HRV measures for identifying certain arrythmic episodes for example then you might want to
avoid preprocessing the RR time series or to use a weak preprocessing in order to only remove outliers beats. Indeed,
in this use case you will want to capture the important irregularities (e.g. atrial fibrillation) in the RR intervals of the

time series.

16
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1.5 Heart Rate Variability analysis

In this tutorial you will learn how to compute the Heart Rate Variability (HRV) measures and export the computed
values within the PhysioZoo HRV analysis module. You will learn how to analyse a single window of defined
length and a series of consecutive windows.

1.5.1 Introduction

HRV analysis is particularly interesting because it provides a non-invasive way to monitor cardiac function and the
autonomic system activity. In particular, in the context of animal studies, HRV tools can be used to study the effects
of mutations and pharmacological treatments. PhysioZoo provides the framework and tools for performing HRV
analysis from human and animal model data.

1.5.2 Why mammal specific HRV?

Because the heart rate range, dynamics and autonomic control can vary significantly between mammals, some HRV
measures need to be adapted to the mammal whose data are being analysed. As an example, the following figure
illustrates the important differences in the location of the characteristic power spectral peaks in analysing RR time
series from different mammals using power spectral analysis. This highlights the need to re-define the spectral bands
(VLF, LF and HF) for each mammal.

AT ’ B3
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ko) —Welch ko) —Welch
20,04} AR >0.08} —AR
G G |
80.03 ﬁ| 20.06 ’|
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] | || J U \
(] VL a \
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L 2 1
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1.5. Heart Rate Variability analysis
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1.5.3 Performing HRV analysis

Start by loading some example data by clicking File -> Open data file -> mouse/Mouse_example_qrs.txt. The program
will start the analysis automatically and display the following window:

@ PhysioZoo

File Peak Detection

Main | Single  Options | Display C:\Users\Joachim. T-BM-YY-L6\Deskiop\physiozoo-physiozoo-toolbox-8d644 191c063\ExamplesTX Timouse\Mouse_example_qrs.txt | compute |
File name Mouse_example_qrs.txt A ! ! ! ' ' ' ' ' ' ' prm——
Signal qualty file name 02
Time series length 00:39:37.784 h'min‘sec.msec 5 Mm ﬂ »{Jﬂ a1 Lo

& 01 MLIM\ i'[‘*' iﬂﬂﬂma‘,{l \\! iy y}'ﬁr‘%
Mammal Mouse M o ;
© 005 - R
Integration level ECG .
ol 4
AT Moving average e Time series Selected fitered time series
005 . . L I I L I I L I 1
Preprocessing level Default M
00:00:00 00:00:50 00:01:40 00:02:30 00:03:20 00:04:10 00:05:00 00:05:50 00:06:40 00:07:30 00:08:20
Defautt frequency method \yelch w0 Time (h:min:sec)
B 0.2
PR i M
. M . .
00:00:00 00:08:20 00:16:40 00:25:00 00:33:20 g g
Statistics Time Frequency NonLinear
Description Values
AVNN (ms) \Average NN interval duration 106.34 ~
SDNN (ms) Standard deviation of NN interval duration 11.89 C
RMSSD (ms) The square root of the mean of the sum of the squares of differences between adjacent NN intervals 6.05
NN (%) Percent of NN interval differences greater than 5.0milliseconds 27.23
SEM (ms) Standard error of the mean NN interval 029
PIP (%) Percentage of inflection points in the NN interval time series 36.66
1ALS (nu) Inverse average length of the acceleration/deceleration segments 037
PSS (%) Percentage of short segments 3074
PAS (%) The percentage of NN intervals in alternation segments 8.37
B WELCH (nu) Slope of the linear interpolation of the spectrum in a log-log scale for frequencies below the upper bound of the VLF band -0.34
HF NORM WELCH (%) High frequency power in normalized units: HF/(Total power - VLF)*100 (welch) 19.03
HF PEAK WELCH (H2) Peak frequency in the high frequency band (welch) 137
HF WELCH (ms~2) Power in the high frequency band (welch) 11.20
LF NORM WELCH (%) Low frequency power in normalized units: LF/(Total power - VLF)*100 {welch) 80.97
LF PEAK WELCH (H2) Peak frequency in the low frequency band (welch) 0.27
LF WELCH (ms*2) Power in the low frequency band (welch) 47.64 .

In the upper figure (A) the selected window (colored in blue) defines the time interval for which the HRV measures
are computed. In the lower panel (B), the RR time series is plotted. Two windows are drawn on it: one window with
a red frame and one with a blue frame (and alpha color from within.) The red window defines the part of the RR
time series plotted in the larger upper figure (A). The blue frame defines the part of the RR time series for which the
HRYV measures will be computed. The window can be modified (extended/shrunk/moved) using the mouse. Pannel
(C) shows all the HRV measures that have been computed.

Congrats! You have made your first HRV analysis with PhysioZoo!

Note: Every time you move the analysis window to another location the newly selected segment will be automatically

analyzed. You can disable this by deselecting the checkbox “Auto Compute” located under the “Compute” button.

Note:

The length of the selected window is important. Some HRV measures assume that the RR time series is

stationary over the selected window. In our context stationary means that the statistical properties of the RR time
series (such as mean and standard deviation) are about constant. Other measures such as the detrended fluctuation
analysis ones do not assume stationarity and thus a long window may be used.

18
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1.5.4 Exporting HRV measures

You can export the HRV measures and prefiltered NN intervals generated by PhysioZoo. Go to File -> Save HRV
measures. The following window will display:

4 Save HRV Measures Options - O s

Select measures to save:

HRV Measures
PSD Measures
MSE Measures
Filtered Data

Save As Cancel

You can select the computation(s) you want to save with the checkboxes:
* HRV Measures: The HRV measures as displayed in the ‘Statistics section’ of the user interface.

* Power Spectral Density: the measure of signal’s power content versus frequency. This corresponds to saving
the power content for each frequency bin of the power spectral density displayed under the ‘Frequency tab’.

¢ Multi Scale Entropy: the value of sample entropy for a range of scales as specified under Options->NonLinear
and displayed under the ‘NonLinear tab’.

* Preprocessed RR intervals: the RR interval time series after it was preprocessed by the filter you specified
under Main-> Preprocessing. The resulting preprocessed time series is traditionally called the ‘NN’ time series.

Select the location where you want to save the HRV measures. Open the HRV Measures file and you will see the list
of HRV measures together with their definitions and values for the window that was selected. For that purpose open
the text file (Mouse_example_qrs_hrv.txt) you just saved.

1.5. Heart Rate Variability analysis 19
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| Mouse_example_ars_hrv - Notepad
File Edit Format View Help

%\/NN (ms) Average NN interval duration 186.34
SDNN (ms) Standard deviation of NN interval duration 11.89
RMSSD (ms) The square root of the mean of the sum of the squares of differences between adjacent NN intervals 6.05
pNNS (%) percent of NN interval differences greater than 5.emilliseconds 27.23
SEM (ms) Standard error of the mean NN interval 9.29
PIP (%) Percentage of inflection points in the NN interval time series 36.66
IALS (n.u.) Inverse average length of the acceleration/deceleration segments .37
PSS (%) Percentage of short segments 36.74
PAS (%) The percentage of NN intervals in alternation segments 8.37
BETA_WELCH (n.u.) Slope of the linear interpolation of the spectrum in a log-log scale for frequencies below the upper bound of the VLF band -0.34
HF_NORM_WELCH (%) High frequency power in normalized units: HF/(Total power - VLF)*1080 (welch) 19.03
HF_PEAK_WELCH (Hz) Peak frequency in the high frequency band (welch) 1.37
HF_POWER_WELCH (ms~2) power in the high frequency band (welch) 11.20
LF_NORM_WELCH (%) Low frequency power in normalized units: LF/(Total power - VLF)*1@@ (welch) 80.97
LF_PEAK_WELCH (Hz) Peak frequency in the low frequency band (welch) 9.27
LF_POWER_WELCH (ms~2) Power in the low frequency band (welch) 47.64
LF_TO_HF_WELCH (n.u.) Low frequency band to high frequency band power ratio (LF/HF) (welch) 4.25
TOTAL_POWER_WELCH (ms~2): Total power (welch) 117.94
VLF_NORM_WELCH (%) Very low frequency power in normalized units: (welch) 45,54
VLF_POWER_WELCH (ms”2) Power in the very low frequency band (welch) 53.71
BETA_AR (n.u.) Slope of the linear interpolation of the spectrum in a log-log scale for frequencies below the upper bound of the VvLF band -0.85
HF_NORM_AR (%) High frequency power in normalized units: HF/(Total power - VLF)*100 (ar) 20.95
HF_PEAK_AR (Hz) Peak frequency in the high frequency band (ar) 1.45
HF_POWER_AR (ms”2) Power in the high frequency band (ar) 7.11
LF_NORM_AR (%) Low frequency power in normalized units: LF/(Total power - VLF)*100 (ar) 79.05
LF_PEAK_AR (Hz) peak frequency in the low frequency band (ar) 9.36
LF_POWER_AR (ms~2) Power in the low frequency band (ar) 26.82
LF_TO_HF_AR (n.u.) Low frequency band to high frequency band power ratio (LF/HF) (ar) 3.77
TOTAL_POWER_AR (ms*2) Total power (ar) 69.77
VLF_NORM_AR (%) very low frequency power in normalized units: (ar) 47.74
VLF_POWER_AR (ms~2) Power in the very low frequency band (ar) 33,31
SD1 (ms) NN interval standard deviation along the perpendicular to the line-of-identity 4.28
5D2 (ms) NN interval standard deviation along the line-of-identity 16.19
alphal (n.u.) DFA low-scale slope 1.32
alpha2 (n.u.) DFA high-scale slope 9.96
SampEn (n.u.) Sample entropy 0.88

1.5.5 Exporting figures

Figures can be exported in high quality format and thus easily included in your research reports or papers. For
exporting figures click File -> Export figures. You will be prompted with the following window on which you can
choose what figures you want to export. After clicking ‘Save As’ you will be able to choose the format of the figure.

4. Save Figures Options — O b

Select figures to save:
| NN Interval Distribution

| Power Spectral Density
| Beta

| DFA

| MSE

| Poincare Ellipse

| RR Time Series

Save As Cancel
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1.5.6 Consecutive windows analysis

You might want to track the evolution of the HRV measures over time: for example, if you are injecting some drug to
the mammal and want to observe the resulting changes on the HRV measures over time. For that purpose PhysioZoo
enables the analysis to be performed on consecutive segments.

Let’s use a long RR time series: File -> Open data file -> Mouse_example_qrs

Click the “Single” Submenu in the left panel and click on the “Use full length” button. Then press the “Compute”
button located on the top right of the interface. You will see the following screen, which contains all the HRV measures
for each consecutive window over the whole recording.

@ PhysioZoo - X
File Peak Detection 1
Main Single | Options  Display C:\U Joachim. T-BM-YY-L6\Ds P physiozoo-toolbox-8i644 19 TXT\ : example_qrs.txt
; T T T
Batch analysis ag | i TR o
Segment start 00:00:00 | himin:sec Plot HR
Segment end 00:39:37 |himin:sec [ENAIETG . 02 7
Window length 00:03:00 |h:min:sec §
Overlap 0 % E 0.1 R
Selected window 1
Number of windows 13 of 1
Time series Selected filtered time series
01k . . . . E
00:00:00 00:08:20 00:16:40 00:25:00 00:33:20
Time (h:min:sec)
02
0.1 4
00:00:00 00:08:20 00:16:40 00:25:00 00:33:20
Statistics Time Frequency | NonLinear
Description w1 w2 w3 W4 W5 W6 W7
AVNN (ms) |Average NN interval duration 106.34 105.94 103.58 107.91 108.49 119.05 11471 104
SDNN (ms) Standard deviation of NN interval duration 11.89 1137 1038 862 1019  11.76 1161 10
RMSSD (ms) The square root of the mean of the sum of the squares of differences between adjacent NN intervals 6.05 5.47 4.96 510 5.02 7.40 637 XS
PNNS5 (%) Percent of NN interval differences greater than 5.0milliseconds 27.23 23.77 2225 22.58 20.52 37.46 29.06 19
SEM (ms) Standard error of the mean NN interval 029 0.28 0.25 021 0.25 030 0.29 0.
PIP (%) Percentage of inflection points in the NN interval time series 36.66 33.23 3538 41.40 38.66 46.21 44.62 36
1ALS (nu) Inverse average length of the acceleration/deceleration segments 037 033 035 0.41 039 0.46 0.45 0.
PSS (%) Percentage of short segments 30.74 24.06 27.50 3591 32.06 42.95 41.03 30
PAS (%) The percentage of NN intervals in alternation segments 8.37 5.10 6.20 12.07 10.65 19.48 14.87 9.2
B WELCH (nu) Slope of the linear interpolation of the spectrum in a log-log scale for frequencies below the upper bound of the VLF band -0.34 124 -0.70 -1.19 -1.45 -0.94 -0.64 0.
HF NORM WELCH (%) High frequency power in normalized units: HF/(Total power - VLF)*100 (welch) 19.03 1407  17.81 2144 1932 2434 2219 10
HF PEAK WELCH (Hz) Peak frequency in the high frequency band (welch) 137 136 1.94 127 167 1.90 1.40 1:
HF WELCH (ms”2) Power in the high frequency band (welch) 1120 1292 871 839 774 1792 793 ac
LF NORM WELCH (%) Low frequency power in normalized units: LF/(Total power - VLF)*100 {welch) 8097 8593 8219 7856 8068 7566 7781 89
LF PEAK WELCH (H2) Peak frequency in the low frequency band (welch) 027 027 0.17 020 0.44 026 027 0.z
[ . DAwiar in tha lau franisancu hand fualch) A7 /A 72 02 Anon an7a 2721 =870 2770 22V
<

You can also enable the analysis window to be overlapping by using the “Overlap” entry in the Analysis menu.
default the value is 0% (i.e. no overlap between successive windows). Change it to 50% and re-run the analysis.

You can export all HRV measures from all consecutive windows (Main -> Save HRV measures as).

If you want to export figures, then select with the mouse the window you want to save the figures for.

Note: While using the successive segment analysis feature, it is possible to export the HRV measures and PSD from
all the analyzed consecutive windows together. However, you can only export the figures from one single window at
the time i.e. from the window that you select with the mouse (i.e. the ‘selected window”).
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1.5.7 Adapting HRV measures to alternative mammals

If you want to adapt the HRV measures to other mammals you can create a new ‘Configuration file’ (see here) with
parameters suitable to the specie you are studying. For some of the HRV measures (power frequency bands and
pNNxx) you will find a button ‘E’ next to their parameters value under Options->Time/Frequency. You can use click
on this button to adapt the HRV measure to the alternative mammalian model you are using.

Main Single Options Display

Filtering Time Frequency MonLinear

AR order 30 n.u.

[3 band 0.0056 |- 0152 |Hz

HF Band 124 |- 5 Hz

LF Band 0152 |- 124 H
VLF Band 0.0056 |- 0152 |Hz
Welch overlap 50 %
Spectral window length 00:03:00 h:min:sec

[ ]Use window average

1.5.8 Video Example
1.6 Signal quality annotations

In this tutorial you will learn how to perform signal quality annotations within the PhysioZoo Peak detection
module and how to use these for your analysis in order to provide contextual information.

1.6.1 Introduction

PhysioZoo allows you to annotate and load signal quality annotations, which contain time intervals with quality
annotations made on the original electrophysiological signal time series. The annotations highlight parts of the RR
time series which are not to be trusted because the underlying ECG was of bad quality and the peak detector might have
failed in estimating the heart rate within these intervals or just because you want to exclude these segments because
they correspond to some transition period during drug injection and so you decide to label these time periods as ‘bad
quality’.
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1.6.2 Annotating signal quality

To annotate the quality of an electrophysiological signal time series, follow these steps:
1. Select the rabbit ECG example: File-> Open data file-> Rabbit_example.txt
2. Under the record panel, select Annotation -> Signal quality. See the red rectangle on the figure below.

3. Look for a segment with some bad quality data and draw a rectangle around it with the mouse. The background
of the area you have selected will become red.

PhysioZoo_PeakDetection - X
File »
Record Configuration Display Ci\Users\Joachim. T-BM-YY-L6\Desktop! i0z00-physiozoo-toolbox-8d644191c06: \plesTXT\rabbi it_example_ecg.txt | compute |
Record file name Rabbit_example_ecg.txt = 6 [ Auto Com
\
Peaks file name: 4l \ \ Plot HR
Sttty o e s, | |
Al |
Time series length 0:26:0.277 h:min:sec.msec ) +
O 0 d *
w
Mammal Rabbit v | ‘
2k
Integration level ECG v ‘
Peak detector rars w Al L L L L L
00:18:00 00:18:10 00:18:20 00:18:30 00:18:40 00:18:50
Annotation Signal quality ~ Time (sec)
Class c v 5 1F 1
- l
[ S ‘p S U N " | — ,%,,;MU,‘,,M
2 ok I L L L
« »
| 00:00:00 00:08:20 00:16:40 00:25:00 gg
Description Values
NB PEAKS (n.u) Total number of peaks 5449
NB PEAKS ADD (n1) Number of peaks manually added by the user 0
NB PEAKS RM (n.u) Number of peaks manually removed by the user 0
PR BAD 5Q (%) Percentage of the record annotated as bad quality (i.e. signal quality = 'A’) 07341

In PhysioZoo we define three levels of signal quality:

* “A”: good quality signal where HRV and morphological analysis of the electrophysiological signal are possible.
This means that the waveform is clean enough to detect the beats and to also study its morphology.

* “B”: average quality signal where the beats can be detected and thus HRV analysis is possible but the signal
quality is not good enough for morphological analysis.

e “C”: bad quality signal. Neither HRV or morphological analysis is possible.

1.6.3 Loading signal quality

When using a recording for which you have performed signal quality annotations, you can load the signal quality
annotations: Open -> Open signal quality file.

After the quality annotations are loaded, you will see a bar with green and red parts appearing on the top of the RR
interval time series figure. The part in green corresponds to good quality data (i.e. data which analysis can be trusted)
and the part in red corresponds to bad quality data (i.e. data which should not be trusted.) In addition, the RR time
series is highlighted in red for the intervals which are indicated as bad quality.
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@ PhysioZoo

- x
File Peak Detection L
Main Single  Options  Display C:\Users\Joachim.T-BM-YY-L6\D i physic 8644 19106 STXT\rabbit it_example_qrs.txt _
- T T T - T T T
File name Rabbit_example_qrs. it 045 p—
Signal quality file name  Rabbit_example_ecg_quality.txt e | | PotHrR |
Time series length 00:25:50.974  h:min:sec_msec =
& 03 WWMWWAW M\rl\v
Mammal Rabbit v x
© 025
Integration level ECG v
- 02
IEEEEs Moving average e 05 Time series Selected filtered time series Bad quality
Preprocessing level Default v . . L . L L
00:17:20 00:17:40 00:18:00 00:18:20 00:18:40 00:19:00
Default frequency method |yyerch % Time (h:min:sec)
0.4
035 Q
Al
@9 ! .| ey Aot
00:00:00 00:08:20 00:16:40 00:25:00
Statistics Time Frequency  NonLinear
Description Values
AVNN (ms) Average NN interval duration 278.06 ~
SDNN (ms) Standard deviation of NN interval duration 8.82
RMSSD (ms) The square root of the mean of the sum of the squares of differences between adjacent NN intervals 5.17
oNN17 (%) Percent of NN interval differences greater than 17.0milliseconds 0.37
SEM (ms) Standard error of the mean NN interval 0.27
PIP (%) Percentage of inflection points in the NN interval time series 4968
1ALS (nu) inverse average length of the acceleration/deceleration segments 0.50
PSS (%) Percentage of short segments 4875
PAS (%) The percentage of NN intervals in alternation segments 20,67
B WELCH () Slope of the linear interpolation of the spectrum in a log-log scale for frequencies below the upper bound of the VLF band 057
HF NORM WELCH (%) High frequency power in normalized units: HF/(Total power - VLF)*100 (welch) 215
HF PEAK WELCH (Hz) Peak frequency in the high frequency band (welch) 0.72
HF WELCH (msh2) Power in the high frequency band (welch) 7.76
LF NORM WELCH (%) Low frequency power in normalized units: LF/(Total power - VLF)*100 (welch) 57.85
LF PEAK WELCH (H2) Peak frequency in the low frequency band (welch) 0.14
LF WELCH (ms2) Power in the low frequency band (welch) 1065 .

1.6.4 Frequently asked questions

When do we need to make signal quality annotations?

Small bad quality segments (few of beats) will be ‘cleaned up’ by the prefiltering step and so one should not worry too
much about it. The signal quality annotations are more useful when a ‘large’ section of the recording is of bad quality
in which case the prefiltering step will be useless or even misleading. Analysing such sections with large segments of
bad quality data will provide meaningless results - the signal quality annotations are useful to prevent that.

1.7 Importing data

In this tutorial you will learn how to import data in PhysioZoo.
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1.7.1 Introduction

Data loading in PhysioZoo is centralized and done through the PZ Loader tool. Three types of input formats are
supported by PhysioZoo - see formats supported.

1.7.2 Concepts

* PZ Loader: three types of formats can be loaded in PhysioZoo. This is done through the PZ Loader. The
PZ Loader will ensure that the data that enter the PZ—-UT are properly formatted.

* Header: itis possible to include a header at the beginning of a record. This header will specify all the information
that PhysioZoo needs to open a record. If all the information is specified in the header, then you will not need
to go through populating the PZ Loader User Interface and the record will be directly opened in PhysioZoo.

See here for the formats supported and how to create PhysioZoo headers.

The figure below illustrates the pathway for loading a recording: the PZ Loader is used to load a recording from
one of the supported formats. If no header is available, then the PZ Loader user interface is opened and the user is
prompted to enter the necessary information. If the header is available, then the record is directly loaded in PhysioZoo.

PZ Loader
User interface
WFDB
Text (.txt) —— | 274 o262 Header? PhysioZoo
Matlab
(.mat)

In this tutorial we will see how to make use of the PZ Loader user interface (UI) when no header is available.

1.7.3 PZ Loader User Interface

Open an example annotation file:
Download the following example file and load it in PhysioZoo.

In case some information is missing from the file (e.g. mammal type is not available in the header) then the PZ
Loader will request the corresponding fields to be filled by the user. When all the fields have been filled then click
OK and the data will be opened in PhysioZoo.

For the example provided, fill the fields as in the screenshot below and click OK:

1.7. Importing data 25


../tutorials/pzformats.html
../tutorials/pzformats.html
../../_static/Dog_05_eg_no_header.txt

PhysioZoo Documentation

PZ Loader

File name: Dog_05_eg_no_header

rGeneral ‘Channels

Time
Integration level |e|ectrocardiogram V| = 500 Name |Ch01 V‘ Unit |second v|
Mammal |d09 "|

Data

Type Name | Ch02 ~ Unit milivolt |

0.4 .
s
Z 02 .
:
3 0
E
2
502} |
| | | | | | | | |
0 05 1 15 2 25 3 35 4 45

Time (sec)

OK Cancel

1.8 Formats supported

In this tutorial you will learn about how to prepare your data for importing them in PhysioZoo. Data samples are
available here.

1.8.1 Introduction

PhysioZoo supports three types of formats:
* WFDB,
o text (.txt),
¢ MATLAB (.mat).

The .txt and .mat files structures are specific to PhysioZoo whereas the WFDB follows the standard structure of WFDB
powered by Physionet (physionet.org) with some additional fields in the WFDB header files. If you are experienced
with WFDB then we recommend you use this format.

For any of the three formats a file consists of a “header” and the “data’:
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Mammal :
Fs:

Integration level: electrocardiogram

Channels:

- type:
name :
units:
enabl

- type:
name :
unit:
enabl

0.000000
0.002000
0.004000
0.006e000
0.008000
0.010000
0.012000
0.014000
0.01le000
0.018000
0.020000

dog
500

time

time

second
e: yes

electrography
data
millivolt

e: yes

0.060057
0.064323
0.068589
0.073524
0.077790
0.080550
0.08356l
0.085987
0.088747
0.090002
0.090002

— Header

— Data

Note: When downloading PhysioZoo a set of examples (WFDB,.txt and .mat) are provided with the structure that is
needed in PhysioZoo. You can use these as examples for formatting your own recordings.

1.8.2 General structure of the Header

For each of the files the following information can be specified in the header:

* Mammal: the name of the mammal (e.g. ‘dog’, ‘mouse’, ‘rabbit’, ‘human’),

* Fs: the sampling frequency in Hertz,

* Integration_Level: ‘electrocardiogram’, ‘electrogram’ or ‘action potential’.

As part of the header, information characterizing each channel available can be entered:

e type: ‘peak’, ‘signal quality’, ‘time’, ‘interval’, ‘beating rate’ and ‘electrography’. See definitions of these in
ype: p gnal q y g grapny

the next section,

* name: a name you want to give to the channel (of note this information is not used by the PZ Loader to load the

data),

* unit: ‘millisecond’, ‘second’, ‘index’, ‘bpm’, ‘millivolt’, ‘microvolt’ and ‘volt’,

 enable: ‘yes’ or ‘no’. If you specify ‘no’ then this channel will be ignored when the file is loaded by the PZ

Loader. Only specify ‘yes’ for the channels you want to use.

In the case all or some of this information is missing from the Header then you will be prompted to enter it through

the PZ Loader User Interface.

1.8. Formats supported
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1.8.3 Channels Type

There are two categories of Channels: ‘Annotations’ and ‘Time series’. Within these two categories the Channel can
be one of the following type’s (specified in the header):

Annotations

* ‘peak’: the location of the peaks (e.g. R-peak from an ECG time series). The peak locations can be
specified in millisecond/second or index.

 ‘signal quality’: annotation on the signal quality. The signal quality annotations can be specified in mil-
lisecond/second or index.

Time series

* ‘time’: a time vector giving the position of each sample of another time series. An entry of type ‘time’
needs to be associated with another time series and must be in units of seconds or milliseconds.

* ‘interval’: the time interval between consecutive beats (e.g. RR time series). The interval length can be
specified in second/millisecond or index.

* ‘beating rate’: the reciprocal of the interval in units of beats per minute (e.g. heart rate).

¢ ‘electrography’: the amplitude of an electrography time series (e.g. ECG). The electrography amplitude is
given in microvolt, millivolt or volt. Thus only physiological units are allowed.

1.8.4 Headers in the different formats

Explanation of the structure of the different formats supported is provided below. Examples in all formats are also
available in the ‘Examples’ folder provided with the PhysioZoo download.

Text format (.txt)
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Mammal : dog
Fs: 500
Integration_level: electrocardiogram
Channels:
- type: time
name : time - Header
unit: second
enable: yes
- type: electrography
name data
unit: millivolt
enable: yes

0.000000 0.060057
0.002000 0.064323
0.004000 0.068589
0.006e000 0.073524
0.008000 0.077790 .

0.010000 0.080550 Data
0.012000 0.08356l
0.014000 0.085987
0.01le000 0.088747

0.018000 0.090002
0.020000 0.090002

Matlab format (.mat)
A .mat file needs to contain the following fields:
| Channels = |
[E] 1x1 struct with 4 fields
Field + |"-.f’alue
abc| AMe 'data'
enable 'ves'
type 'alectrography
Jaod unit ot

The Channels field is a Cell. Each element of the Channel Cell will contain the following fields : ‘type’, ‘name’, ‘unit’
and ‘enable’.

WFDB (.hea)

WEFDB files (annotation or data) will be accompanied by a header (.hea) file specifying the relevant information for
reading an annotation or data file. Refer to the WFDB documentation for that. To the standard WFDB format of the
header, you will need to add one comment line at the end of the header and starting ‘#’ then followed by the mammal
type and the integration level.
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Dog 01 1 500 134258

Dog 0l.dat 16 51300.0027(-1159)/mV 0 0 —-1487 25886 0 Data
(electrography)

#Mammal :dog, Integration level:electrocardiogram

1.8.5 Frequently asked questions
What if | am used to another format?

For now PhysioZoo only supports the WFDB, text and Matlab formats. Most commercial softwares enable you to
export your data in text format which you can then import in PhysioZoo using the PZ Loader (see here).

Is there a way to import data without a formatted header?

Yes you can use the PZ Loader (see here) to import data which do not have a Header. You will use the PZ Loader
User Interface to fill in the information needed and it will be opened in PhysioZoo.

1.9 Configuration files

In this tutorial you will learn how to create your custom configuration files for R-peak detection and for performing
HRYV analysis.

Note: In the next version of PhysioZoo the two configuration files will be merged in one unique configuration file.

1.9.1 Introduction

PhysioZoo enables you to work with HRV data from different mammals. Since the beating rate and its variability
patterns vary across species then some parameters of the peak detectors and of the time, frequency and nonlinear HRV
measures must be adjusted.

In the current version of the software these adaptations are readily available for the processing of Human, dog, rabbit
and mouse electrocardiographic data. For processing data from other species or if you are using other data than ECG
(e.g. electrogram, action potential) you will need to define your own configuration files. There are two types of
configuration files in PhysioZoo: the peak detection configuration file and the HRV configuration file.

1.9.2 PhysioZoo software
Defining a peak detector configuration file

In the Peak detection module:

1. By choosing Mammal->Custom this will prompt you with a selection window. Select the configuration file of
the closest mammal to the one you want to use. This will set the default HRV configuration parameters. Follow
the following steps:

2. Modify the configuration of the peak detector you choose to use uder Configuration.
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3. Save the peak detector configuration by clicking File -> Save configuration file.

4. To use this configuration file when you next use the PhysioZoo peak detection module: (1) File->Load custom
config file or (2) Main->Mammal->Custom and choose your configuration file.

_| gqrs.custom - Notepad — O

File Edit Format View Help

# gqrs temp config file for custom parameters:
HR 608

QRSa 109@

QRSamin 37@

Qs 9.00718

QT 0.03

RRmax 9.24

RRmin  @.@5

hct 300
lcf 3

rp 0.030
thr 2.5
W5 1@

Defining an HRV configuration file

In the HRV module: under the “Main” tab you can change the Mammal type to one of the following options: Human,
Dog, Rabbit, Mouse and Custom. In built in the software are configuration files for human, dog, rabbit and mouse
electrocardiographic data. By choosing thee “Custom” option under "Mammal’ you can define an HRV configuration
file of your own. Follow the following steps:

1. By choosing Mammal->Custom this will prompt you with a selection window. Select the configuration file of
the closest mammal to the one you want to use. This will set the default HRV configuration parameters.

2. Modify some of the HRV measures configuration by going to the “Options” menu (see screenshot below.) There
you will find all the parameters of the HRV measures sorted with respect to their category: Time, Frequency and
Nonlinear as well as the Preprocessing parameters. If, as an example, you want to change the cut-off frequency
between the low frequency and high frequency bands (“LF Band” and “HF Band”) in the frequency based
methods then you can do so by changing the 0.341 Hz (see screen below) value to something else more suited
to your data.

3. Go to File->Save config file and save the configuration file under the name of the mammal you are using.

4. To use this configuration file when you next use PhysioZoo HRV module: (1) File->Load custom config file or
(2) Main->Mammal->Custom and choose your configuration file.
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File Help Peak Detection

Record = Analysis  Options

qrs_Rabbit_02_part 4 mat

Display Group

Peaks file name
Quality file name

Time series length 00:25:59 988 h:min:sec.msec

Mammal Rabbit 7
Integration level Auman

Human (Task Force)
Preprocessing Dog
Preprocessing level Mouse

Custom

Default frequency method yyeprm

Auto Compute

il

File Help Peak Detection

Record  Analysis  Options Display Group
Filtering Time Frequency MNonLinear

AR order 20 n.u.
¢ band 0.0033 |-| 0.088 Hz
HF Band 0341 - Hz
LF Band 0.088 Hz &
VLF Band 0.0033 |-| 0.088 Hz
Welch overlap 50 %
Spectral window length 00:05:00 h :min-sec

[ 1Use window average

:

.
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1.9.3 Frequently asked questions
Why configuration files?
The beating rate and its variability pattern vary across species thus some parameters of the peak detectors and of the

time, frequency and nonlinear HRV measures must be adjusted.

1.10 Rhythm annotations

In this tutorial you will learn how to perform rhythms annotations from raw ECG recording within the PhysioZoo
Peak detection module.

1.10.1 Introduction

PhysioZoo enables you to annotate and load rhythm annotations i.e. timestamped rhythm annotations marking the
beginning and the end of a given rhythm. For example, thythm annotations may have been produced by an original
automated analysis machine (e.g. Holter ECG software) that you which to review and edit. The heart rhythms for wish
annotations exist in PhysioZoo are:

Table 1: Available rhythms in PhysioZoo

Abbreviation Condition

AFIB Atrial fibrillation

AB Atrial bigeminy

AFL Atrial flutter

B Ventricular bigeminy

BII 2° heart block

IVR Idioventricular rhythm

NOD Nodal (A-V junctional) rhythm

P Paced rhythm

PREX Pre-excitation (WPW)

SBR Sinus bradycardia

SVTA Supraventricular tachyarrhythmia
T Ventricular trigeminy

VFL Ventricular flutter

VT Ventricular tachycardia

J Junctional rhythm

PAT Paroxysmal atrial tachycardia

AT Atrial tachycardia

IVR Idioventricular rhythm

AIVR Accelerated idioventricular rhythm

1.10. Rhythm annotations
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1.10.2 Annotating rhythms

To annotate the quality of an electrophysiological signal time series, follow these steps:
1. Select the following ECG example: File-> Open data file-> physiozoo\ExamplesTXT\rhythms\ECG.txt.

2. Under the record panel, select Annotation -> Rhythms. See the red rectangle on the figure below. The different
options will be displayed below in the same panel.

3. Draw a rectangle with your mouse on the desired window. The background behind the selected window will be
displayed in color.

4. The rhythms can be exported under a .txt file: File -> Save Rhythms file (Ctrl+T).

PhysioZoo_PeakDetection - X
File

Record Folder Configuration  Display _
cit hocriD XTirhythms\ECG.txt
Record file name: ECG it - = rhythms [ Auto Compute
Peaks file name: .. ] | PlotHR |
Signal quality file name: .. |
AFIB
Rhythms file name: ..
Config file name: qrs human-ecg yml .. | - e
nnnnn isplay
Time series length:  00:08:19.995 himinsec.msec 0441 1 |pata
Mammal human =
s
Integration level ECG E
[o}
Peak detector rars @ 086
Annotation Rhythms v
Rhythms AFIB
|
| -1 -] - |
n a5 | | | I I I I I
00:08:08  00:08:09  O00:08:10  00:08:11  00:08:12 000813  00:.08:14  00:08:15  00:08:16  00:08:17  00:08:18  00:08:19
| o | Time (hminsec)
| - .
2]
3 4
[ [ Y
EN ENEN
. | .
] o wowm  oosdo  Gooeoo  Woex ook oooreo  oowao  wwordo 000800 [T |
Peaks Rhythms

NE PEAKS (n.u) Total number of peaks 85
NB PEAKS ADD (n.u) Number of peaks manually added by the user 0
NB PEAKS RM (n.u.) Number of peaks manually removed by the user 0

PRBADSQ (%) Percentage of the record annotated s bad quality (i.e. signal quality ='A’) 0

T T
Re @D BN g0 By

1.10.3 Loading rhythms

When using a recording for which you have performed rhythms annotations, you can load the rhythms annotations:
Open -> Open rhythms file.

After the rhythms annotations are loaded, you will see a set of shaded areas with different colors appearing on the
top of the RR interval time series figure as well as on the ECG raw data. These areas correspond to the rhythms
annotations and each color is used to represent a different rhythm. These annotations may be further edited/saved.

On the bottom panel, you can find summary statistics for each rhythm: burden, minimal interval length, maximal
interval length and 5 summary statistics.
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PhysioZoo_PeakDetection - X
File
e T eomo] Dein [ Compute |
ca hocr\D XTrhythms \ECG. ¢
Record file name: ECGtxt - o 5 rhythms Auto Compute
Peaks file name: .. ] | _PlotHR |
Signal quality file name: .. | @
Rhythms file name:  RHYTHMS txt - “ar
Config file name: grs human-ecg yml ..
Channels Display
Time serieslength:  00:08:19.995 hmin:sec.msec 5| 1 |pata
Mammal human =
S
Integration level ECG & = 4 i
Peak detector 8or ilh )y IR0
rars v o ‘ i il T I il LY I‘! q J
Annotation Rhythms " i i J M A T il il H H I i i
Rhythms AFIB v [ ‘ ° I ¥ x| i '|” B
ST T ' «
[ Jour] I I
e[ T il
[ o | . . . L . . L . .
00:05:40 00:05:50 00:06:00 00:06:10 00:0620 00:06:30 00:06:40 00:06:50 00:07:00
B Time (minisec)
B
25
 rrex 5 L]
gl ENEN
&0y Hsdrmniainishail gt
| , X
] | 0w oo w0 w00 w0010 =3 EE oo w0 [ [ |

Peaks. Rhythms

Min (sec) | Max (sec) |Medion (sec)| Q1 (sec) | Q3(sec) | Burden (%) | Nbevents

Description
AFIB_|Atrial fibrillation 77070 846700  13.0573  9.0446 667668 210871
B |Ventricular bigeminy 10191 34713 22452 10191 34713 0.8981

SVTA_|Supraventricular tachyarrhythmia 22611 99363 28662 24124 81688  3.0128

Rhythms statistics

1.11 Multi-channel visualization

In this tutorial you will learn how to visualize several ECG channels within the PhysioZoo Peak detection
module.

1.11.1 Introduction

PhysioZoo allows you to visualize several ECG channels in parallel. This can be use to facilitate the review of Holter
recordings for example. This tutorial will show how to display several channels in parallel.

1.11.2 Displaying several channels

To display several channels of an ECG, follow these steps:

1. Select the multi-channel ECG example: File-> Open data file-> physiozoo\ExamplesTXT\multi-lead\multi-
lead.txt.

2. On the right panel, select the desired leads to be displayed. By default, only channel 1 is selected.
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Record Folder

Configuration  Display

CAUserstarmand shocriDoctmeniaphys. repelphysiozo Ecampls TXTymulf-oacmulioad bt O]
Record file name: multi-lead txt .| = [ Auto Compute
Peaks file name: .| | _PlotHR |
Signal quality file name: .| 006 @
Rhythms file name: .|
Config file name: rs. human-ecg.yml Channels | Display
g q g .| T [patar
Time series length: 00:01:39.995 h:min:sec msec 2 |data2
2 094 L data3
Mammal human E ¥ 3
9]
Integration level ECo o f
Peak detector rrs v
Channels selection
Annotation Peak ~ 194
Peak adjustmen Default =
| - ] =1 . |
o I I I I I I I I I I I I I
00:01:09 00:01:10 00:01:41 00:0112 00:01:13 00:01:14 00:0145 00:01:16 00:01:17 00:01:18 00:01:49 00:01:20 00:01:21 00:01:22
Time (h:min:sec)
=
i
208
« . | | | I 1 | | i
| [ oot oo o e weeom wom  were  wome o weiw [ T |
Peaks Rhythms
Description Values
NB PEAKS (n.u) Total number of peaks 10
NB PEAKS ADD (n.u.) INumber of peaks manually added by the user o
NB PEAKS RM (n.u.) INumber of peaks manually removed by the user )
PRBAD 5Q (%) Percentage of the record annotated as bad quality (i.e. signal quality #'A’) )

1.11.3 Frequently asked questions

What is the format of the files to be loaded to PhysioZoo to display several channels ?

If recordings are provided in .mat format then each column will represent a different channel.

An other option is to use a .txt file which will contain the following header:

Mammal: Mammal type (human, rabbit...)
Fs: Sampling frequency
Integration_level: electrocardiogram

Channels:

- type: electrography
name: Channel name
unit: Units (usually mV)
enable: yes

- type: electrography
name: Channel name
unit: Units (usually mV)
enable: yes

- type: electrography
name: Lead name
unit: Units (usually mV)
enable: yes
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Following this header, the user shall place the samples in 3 distinct columns, separated by a space. The user is invited
to open the ‘multi-lead.txt’ example to visualize the file structure.
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2.1 mhrv

2.2 mhrv.

2.3 mhrv.

2.4 mhrv.

2.5 mhrv.

2.6 mhrv.

2.7 mhrv

2.8 mhrv.

defaults

ecg

hrv

rri

wfdb

.util

plots

MHRV TOOLBOX DOCUMENTATION
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INDICES AND TABLES

* genindex
¢ modindex

¢ search
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